Version 0.9.0 – Ready, settings, go!


On the 12/12/12 (what a lovely date) at 20:12 (an appropriate time). We have released version 0.9.0 of our plugin. This version included a major rewrite of our settings and administration page. Moving from the single very long page with oh so many options to a slick tabbed interface.
This version is not only cosmetic but it also included two major features enabled by the settings new advanced tab:
1. Inclusion of debugging support: Now we will be able to give you better support using the plugin ability to create logs, and allow remote debugging.
2. Advanced parsing rules: This feature allows you to change the way texts are being broken for translation on your site. It allows a much finer granulation and fitting the engine to your specific use case.

However – be warned, those features, although well tested are marked advanced and experimental. Use them only if you understand what you are doing.

There are so many other features and bug fixes included, that many of them deserve their own post, but for now, lets go over the change log:
* A new language selection widget based on select2 (Very nice select box with flags)
* Added ctrl keys for quick navigation of previous/next blocks (Improves speed of working with the interface)
* A new option that allows to reset the configuration file to the recommanded defaults
* Css fixes for twenty twelve theme
* Avoid loading the subwidgets in the admin pages
* Removed distinction between editable and viewable languages, now a language can only be active or disabled
* Updating jQueriUI to 1.9.2 (jQuery should now be 1.6+)
* Fixes the z-index for the old style dropdown (patch by chemaz)
* Fixes the bug with the coupling of Chinese simple and traditional
* Fix bug preventing upgrade from very old versions
* Suppress notices when widgets are created directly with our function
* Avoid rewriting urls in the default language, mainly effected canonicals
* Our script is needed when the widget allows setting of default language
* Finally solved the problem with MSN translate and CR/LF

In the days following the initial release, three bugs have been uncovered and fixed, if something simple is not working, make sure to refresh your files.

Enjoy this version!

, , , , ,

  1. #1 by Tim on January 9, 2013 - 6:34 pm

    Hi,

    First of all I would like to appreciate your incredible work, good job !!!

    I am struggling to use transposh with new bing translator setup which has now new approach of using client ID and clientsecret key .

    In transposh it ask for single bing API , however I was expecting 2 fields for each cliendID and ClientSecret

    I may be wrong in approach but my study so far has lead me to this conclusion… Seek your help and guidance if possible.
    Thak you for reading my issue :-)

    • #2 by ofer on January 11, 2013 - 12:28 am

      Hi,

      I agree with the contents of your comments, but I’ll tell you what the situation is and why I am not doing anything about it
      1. The current key free solution works nicely
      2. The old key works for anyone who has such a key
      3. The new key requires a new method of interacting with a temp key (10 minutes life) which is rather annoying

      So, if I’ll fix it, I will have to do tons of work and testing, while harming users with current keys.

      When will I do this? Probably only if the first solution starts to fail miserably, or I find myself with too much spare time (not very likely :) )

      I hope this helps (or at least explains it)

      • #3 by Tim on January 11, 2013 - 2:43 pm

        Thanks for your support… :)

  2. #4 by Marty on January 22, 2013 - 1:30 am

    Ofer, thanks for your work on this plugin.
    As usual with the updates, there is a need to go into parse.php and change some of the settings. This time no matter how I change the settings for punctuation breaks and number breaks, my previous translations for the whole site are lost. I know they’re not lost, just suddenly no longer visible. What has happened to parser and how can I get my translated phrases to load again?
    Thanks
    Marty

    • #5 by ofer on January 22, 2013 - 1:32 am

      Hello Marty,

      Those changes in parser.php got migrated to the advanced tab in the settings, so you won’t have to do that manually any more :)

      Good luck!

  3. #6 by Marty on January 22, 2013 - 1:47 am

    OOOH, I SEE. It’s now on the WordPress side! Fixed. Love it!!!! Thanks, Ofer.

  4. #7 by Dasep on January 27, 2013 - 1:35 am

    hello ofer.

    i would like to thank you very much for your transposh. it made any website or blog easier to rolling the world, even they are newbie just like me. i have apply the transposh 0.9.0 plugins in my sidebar widget, and it’s work.

    but, i need something more from you, please. just for your info, my home page is statics without sidebar of course. :D that’s why, my visitor can not choose their language directly. i think i need a short code. can you give me please?

    thank you

    • #8 by ofer on January 27, 2013 - 1:39 am

      Hello,

      You could look at the FAQ and find code your can include in your theme,

      There are also shortcodes, you can read all about them on our development site at: http://trac.transposh.org

      Good luck

  5. #9 by Angel on February 13, 2013 - 7:44 pm

    Hi
    I suggest to add the compatibility with the search engine o the wordpres. Now we can only search in the default languaje

(will not be published)


Current day month ye@r *